基于协议划分VLAN配置示例

1、组网需求

基于协议划分VLAN配置示例

         图1 基于协议划分VLAN组网图

如图1所示,某企业拥有多种业务,如IPTV、VoIP、Internet等,每种业务所采用的协议各不相同。为了便于管理,现需要将同一种类型业务划分到同一VLAN中,不同类型的业务划分到不同VLAN中。

Switch收到的用户报文有多种业务,所采用的协议各不相同。

VLAN10中的用户采用IPv4协议与远端用户通信,而VLAN20中的用户采用IPv6协议与远端服务器通信。

现需要将不同类型的业务划分到不同的VLAN中,通过不同的VLAN ID分流到不同的远端服务器上以实现业务互通。

2、配置思路

采用如下的思路配置基于协议划分VLAN:

2.1、创建VLAN,确定每种业务所属的VLAN。

2.2、关联协议和VLAN,实现根据接口接收到的报文所属的协议(族)类型给报文分配不同的VLAN ID。

2.3、配置接口加入VLAN,允许基于协议的VLAN通过当前接口。

2.4、关联接口和协议VLAN。当有关联的协议进入关联的接口时,系统自动为该协议分配已经划分好的VLAN ID。

3、操作步骤

3.1、创建VLAN

<HUAWEI> system-view

[HUAWEI] sysname Switch1

[Switch1] vlan batch 10 20

3.2、配置基于协议划分VLAN

# 在Switch1上配置VLAN10与协议IPv4关联。

[Switch1] vlan 10

[Switch1-vlan10] protocol-vlan ipv4

[Switch1-vlan10] quit

# 在Switch1上配置VLAN20与协议IPv6关联。

[Switch1] vlan 20

[Switch1-vlan20] protocol-vlan ipv6

[Switch1-vlan20] quit

3.3、配置接口关联协议VLAN

# 在Switch1上配置接口GE1/0/2与VLAN10关联,优先级是5。

[Switch1] interface gigabitethernet 1/0/2

[Switch1-GigabitEthernet1/0/2] protocol-vlan vlan 10 all priority 5

[Switch1-GigabitEthernet1/0/2] quit

# 在Switch1上配置接口GE1/0/3与VLAN20关联,优先级是6。

[Switch1] interface gigabitethernet 1/0/3

[Switch1-GigabitEthernet1/0/3] protocol-vlan vlan 20 all priority 6

[Switch1-GigabitEthernet1/0/3] quit

3.4、配置接口

# 在Switch1上配置接口GE1/0/1允许VLAN10和VLAN20通过。

[Switch1] interface gigabitethernet 1/0/1

[Switch1-GigabitEthernet1/0/1] port link-type trunk

[Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20

[Switch1-GigabitEthernet1/0/1] quit

# 在Switch1上配置接口GE1/0/2以untagged方式允许VLAN10通过。

[Switch1] interface gigabitethernet 1/0/2

[Switch1-GigabitEthernet1/0/2] port link-type hybrid

[Switch1-GigabitEthernet1/0/2] port hybrid untagged vlan 10

[Switch1-GigabitEthernet1/0/2] quit

# 在Switch1上配置接口GE1/0/3以untagged方式允许VLAN20通过。

[Switch1] interface gigabitethernet 1/0/3

[Switch1-GigabitEthernet1/0/3] port link-type hybrid

[Switch1-GigabitEthernet1/0/3] port hybrid untagged vlan 20

[Switch1-GigabitEthernet1/0/3] quit

# 在Switch上配置接口GE1/0/1允许VLAN10和VLAN20通过。

<HUAWEI> system-view

[HUAWEI] sysname Switch

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20

[Switch-GigabitEthernet1/0/1] quit

# 在Switch上配置接口GE1/0/2允许VLAN10通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 10

[Switch-GigabitEthernet1/0/2] quit

# 在Switch上配置接口GE1/0/3允许VLAN20通过。

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type trunk

[Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 20

[Switch-GigabitEthernet1/0/3] return

4、验证配置结果

上述配置完成后,在Switch1上执行命令display protocol-vlan interface all,可以查看接口关联基于协议划分VLAN的配置信息。

[Switch1] display protocol-vlan interface all

——————————————————————————-

 Interface                VLAN    Index        Protocol Type           Priority

——————————————————————————-

 GigabitEthernet1/0/2     10      0            IPv4                    5

 GigabitEthernet1/0/3     20      0            IPv6                    6

5、配置文件

5.1、Switch1的配置文件

#

sysname Switch1

#

vlan batch 10 20

#

vlan 10

 protocol-vlan 0 ipv4

vlan 20

 protocol-vlan 0 ipv6

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type hybrid

 port hybrid untagged vlan 10

 protocol-vlan vlan 10 0 priority 5

#

interface GigabitEthernet1/0/3

 port link-type hybrid

 port hybrid untagged vlan 20

 protocol-vlan vlan 20 0 priority 6

#

Return

5.2、Switch的配置文件

#

sysname Switch

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk allow-pass vlan 10 20

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk allow-pass vlan 10

#

interface GigabitEthernet1/0/3

 port link-type trunk

 port trunk allow-pass vlan 20

#

return

本文来自网络,本文观点不代表CMCC立场,转载请联系原作者。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注